Tipps und Tricks

Balkendiagramm automatisch sortiert

09. Januar 2017

Das erwähnte Diagramm ist wohl die am häufigsten gebrauchte Darstellung. Sie ist ideal, um zum Beispiel einen Grössenvergleich darzustellen. Excel übernimmt bei der Erstellung die exakte Reihenfolge der vorliegenden Datenbasis.

Beispiel:

Bild Excel Balkendiagramm

Die Darstellung ist korrekt und bekannt. Allerdings stört die Reihenfolge das Auge ein wenig. Noch rascher kann der Mensch das Diagramm erfassen und verstehen, wenn die Balken der Grösse nach sortiert sind.

In der Praxis wird dies durch die Sortierung der Datenbasis gelöst.

Beispiel:

Excel Balkendiagramm  

Der Nachteil dieser Lösung ist, dass jede Änderung eine manuelle Neusortierung benötigt.

Optimal wäre es, wenn die Änderungen automatisch im Diagramm umgesetzt werden. In diesem Beitrag geht es genau darum.

Grundgerüst

Wir listen in der Spalte A einige Automarken auf und versehen die Spalte B mit beliebigen Werten.

Exceltabelle

Nun fügen wir das Balkendiagramm ein.

Balkendiagramm

Hilfspalten verwenden

Als nächster Schritt werden mittels der Verwendung von Hilfsspalten die Basisdaten nach Wunsch sortiert. Dazu verwenden wir die Funktionen =VERGLEICH(), =INDEX(), =KGRÖSSTER() bzw. =KKLEINSTER(). Mit den beiden letzten Funktionen bestimmen wir die gewünschte Sortierung.

Die Spalten D, E und F dienen als Hilfsspalte.

Die Spalte D dient dazu, die Automarken zu nummerieren. Das heisst, Audi = 1, Mercedes = 2 usw.

Exceltabelle

In der Zelle F1 soll der höchste Wert aus der Spalte B stehen. Setzen Sie
=KGRÖSSTE($B$1:$B$6;D1) in die Zelle. Danach die restlichen Zellen darunter auffüllen.

Excelbefehl K Grösste  

Mit den Funktionen =INDEX() und=VERGLEICH() werden die dazugehörenden Bezeichnungen ausgelesen.

Schreiben Sie in die Zelle E1:
=INDEX($A$1:$A$6;VERGLEICH(F1;$B$1:$B$6;0))

Erneut die restlichen Zellen darunter auffüllen.

Exceltabelle

Die Daten der Spalten A und B lassen sich nun beliebig verändern. Die Hilfsspalten sortieren nun automatisch.

Beispiel: Erhöhung bei Volvo auf 92, Verminderung von Audi auf 20

Exceltabelle

Diagramm – Datenbasis verschieben

Klicken Sie auf einer der Säulen im Diagramm. Verschieben Sie die Markierungen von A nach E bzw. von B nach F.

Excel Balkendiagramm

Die Marken sind wertmässig absteigend sortiert.

Unbedingt beachten

Sämtliche Anpassungen dürfen nur in den Spalten A und B erfolgen.

Hat bei Ihnen alles funktioniert? Gerne können Sie die Kommentarfunktion nutzen, um Fragen zu stellen. 

###

Hier finden Sie einen ähnlichen Blogbeitrag von Herrn Jordan " Pareto-Diagramm [EXCEL]". Weitere hilfreiche und interessante Excel Tipps und Tricks finden Sie hier.

Themen: Tipps und Tricks, Accounting und Controlling

Autor: Frederic Jordan

Datum: 09. Januar 2017

Schlagworte: Excel

Verwandte Artikel